DXF export from Sketchup (free version)

From Site 3 coLaboratory Wiki
Jump to: navigation, search

Instructions for my works-with-the-laser workflow using free, legal tools

Preparation

  1. Download SketchUp (tested with version 8)
  2. Download and install the free DXF export plugin
  3. I recommend using the template "Plan View - Meters." To change your template, go to SketchUp preferences and select "templates."
  4. Select "Parallel Projection" under the "View" menu (you can make this the default by going to "File > Save as Template...")

Drawing

Mentally convert your dimensions from millimetres to metres. I.e., if an edge to cut will be 10mm, draw it as 10m. Alternatively, do your drawing in millimetres and scale it up by a factor of 1000 when you're ready to save.

Saving

  1. Select the objects that you want to save. Faces and guides will be ignored. If nothing is selected, it will default to selecting everything (and show a dialogue to this effect).
  2. From the "Tools" menu, select "Export to DXF or STL..." On my machine this is the third option from the bottom.
  3. Select "Meters" as your export unit. Even though other options are given, in my experience none of these will import properly on the laser.
  4. Select "Lines" in the "Choose which entities to export" dialogue. Again, none of the other options will work.
  5. Make sure your filename has a ".DXF" extension; the plugin seems to sometimes delete it.

After importing to the laser software

Import should work without problems. Circles are often made up of many short line segments; to create a more efficient cutting path, choose the "Unite lines" option in the laser software (not sure which menu it's in, because I'm writing from home). I find a "tolerance" value of 0.5 works well.